
In this lesson, you’ll learn how to do the following:

Excerpted from Adobe® InDesign® CS2 Classroom in a Book®

• Import XML tags.

• Apply XML tags.

• Map styles and tags.

• Use the Structure pane.

• Import XML.

• Export XML.

Getting started
In this lesson, you’ll take a completed InDesign layout and apply 

 rm the structure of 
the document, export the contents as XML, and then import the 
XML into another InDesign layout. Before you begin, you’ll need to 
restore the default preferences for Adobe InDesign. 

1 To ensure that the tools and palettes function exactly as 
described in this lesson, delete or deactivate (by renaming) the 

 le. See 
“Restoring default preferences” on page 2.

2 Start Adobe InDesign CS2.
To begin working, you’ll open an existing InDesign document.

Note:  les for this lesson 
onto your hard disk from the Lesson_13 folder from the Adobe 
InDesign CS2 Classroom in a Book CD, do so now. See “Copying the 

 les” on page 4.

3  le in the 
Lesson_13 folder, on your hard disk. 

Using XML
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4 Choose File > Save As, rename the fi le ski_brochure.indd, and save it in the 

Lesson_13 folder.

About XML
eXtensible Markup Language (XML) is used to distribute content, including text and 

images, to multiple destinations. XML separates content from its appearance on a page 

or in a layout. XML fi les use tags that identify the content in the fi le. Because the content 

of an XML fi le is identifi ed with tags, it can be repurposed for distribution in print, on-

line, or in some other format, such as PDF.

XML fi les are not dependent upon a specifi c layout, and can be formatted to match 

the needs of the viewer or viewing device. For example, an XML version of a typical 

brochure might be formatted to display as a traditional vertical layout when printed. 

Th e same information can be converted to a horizontal layout for on-screen viewing as a 

PDF. Th e same content can also be converted to HTML and placed onto a web page. 

While XML allows for data to be presented in a variety of formats, it also has advantages 

for revising and customizing print layouts. When InDesign documents are converted to 

XML, you can easily extract some or all of the data to re-use in other InDesign layouts. 

For example, a single XML fi le can be the source for a sales brochure, a price list, and a 

catalog.

XML

HTML
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If you design web sites using Adobe GoLive or other programs, you may be familiar 

with Hyper Text Markup Language (HTML). While XML and HTML have similar 

names, and both markup languages include tags, they are actually quite diff erent. 

HTML tags describe the appearance of the content in an HTML fi le, and how it should 

be formatted. Conversely, XML tags describe the content itself and do not describe 

formatting. With XML, formatting decisions occur when the XML is placed into a 

specifi c layout.

To use the XML features of InDesign CS2, you do not need extensive XML knowledge. 

To learn more about the XML capabilities of InDesign CS2, choose Help > InDesign 

Help. Th en select XML in the InDesign Help Contents.

Viewing XML tags
InDesign CS2 uses XML tags to identify the type of content that is, or will be, placed on 

a page. Th ese tags are used when XML is either imported or exported from an InDesign 

layout. Frames can be tagged, or specifi ed, to contain certain types of text, such as 

stories or headlines. Frames can also be tagged to contain graphics. Th e same tags may 

be used multiple times within a document. For example, a document may contain 

multiple headlines, and each headline may contain the same tag name identifying it 

as a headline.

 If you regularly work with XML, you may be more familiar with XML elements. Tags 

applied using InDesign CS2 identify the specifi c occurrence of an XML element. 

In this exercise you’ll examine some existing XML tags that have been applied to an 

InDesign CS2 layout.

1 Choose Window > Tags to open the Tags palette. Th e Tags palette opens, displaying 

a list of XML tags that have previously been created with this document.
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2 Choose the Selection tool ( ) and click the text frame containing the text “Snow 

and Ski Report” along the top of the document. Notice that the Title tag in the tags 

palette becomes highlighted as this frame is selected. Th e highlighting indicates that the 

Title tag is applied to this text frame.

3 Choose Edit > Deselect all.

4 Choose the Type tool ( ) and click in the headline text “Great Year to Ski.” In the 

tags palette, the tag Head2 becomes highlighted, indicating that this text also has an 

XML tag applied to it.

5 Choose View > Structure > Show Tagged Frames. Th e two text frames we’ve 

examined display a colored border and background.

Th e border and background color corresponds to the color of the XML tags that are 

applied to the frames. Notice that the Title tag is Magenta and this is the color that is 

displayed around the title of the publication.

6 Choose the Zoom tool ( ) and click and drag a box around the text “Great Year to 

Ski” along with several lines of type beneath this text. Th e magnifi cation of this area of 

the page increases.
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7 Choose View > Structure > Hide Tag Markers. Th e XML tag markers at the start 

and end of the Great Year to Ski headline disappear. Choose View > Structure > Show 

Tag Markers. Markers are displayed to the left  of the word Great and the right of the 

word Ski. Th e markers are purple, which corresponds to the color of the Head2 tag in 

the Tags palette. 

 Tag markers are also visible in the Story Editor. 

8 Double-click the Hand tool ( ) to view the entire page.

Note: Th e tag indicators help identify which objects have been tagged, and these markers 

display only on screen, not when a document is printed.

Importing and applying XML tags
You can create XML tags within your InDesign CS2 layout, or you can import them 

from another InDesign CS2 document or a Document Type Defi nition (DTD). In this 

exercise, you will import several new tags, and then apply the tags to objects in the 

layout.

1 Select the Type tool ( ) and click anywhere in the text of the sidebar titled “Super 

Skiing” along the right side of the document. No tags in the Tags palette are highlighted, 

as tags have not been applied to this text.

When the cursor is placed within tagged text, or when a tagged object is selected, the 

tag applied to the text or object is highlighted in the Tags palette. Because this text is not 

yet tagged, no tag name is highlighted. You will import several new tags, and then apply 

them.
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2 Choose Edit > Deselect All.

3 In the Tags palette, choose Load Tags from the palette menu. Navigate to the 

Lesson_13 folder and choose the tags.xml fi le, then click Open. InDesign adds two new 

tags into the Tags palette: Head1 and Image. You will apply these tags to objects and text 

in your layout.

Note: Th e names of the tags must exactly match those used in your XML workfl ow. XML is 

very precise, causing head1 and Head1 to be considered diff erent tags.

4 In the tools palette, choose the Selection tool ( ), click the text frame containing the 

headline text “Family Fun,” and click the Head1 tag in the Tags palette. Th e Head1 tag is 

now applied to this text frame and all its contents. Th e frame containing the Family Fun 

text becomes blue, refl ecting the tag that has been applied to it.

5 In the Tools palette, select the Type tool ( ). Click and drag to select the headline 

“Good Snow” in the second column. Click the Head2 tag in the Tags palette. Th e tag 

is applied to the selected text. Brackets appear at the start and end of the selected text, 

identifying that the text is tagged. Th e color of the brackets corresponds to the color of 

the tag. If necessary, choose View > Structure > Show Tag Markers to display the text 

tags.

Note: You may need to deselect the text to clearly see the tag markers that are applied to it. 

Choose Edit > Deselect All to deselect the text. 

6 Click and drag to select the body text that follows the “Good Snow” headline. Be 

sure to select the text in the fi nal two paragraphs of this story, at the bottom of the 

second column. While the text is selected, click the Body tag in the Tags palette.
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7 If necessary, scroll to view the sidebar in the far right column of the page. 

Continuing to work with the Type tool, click and drag to select the “Super Skiing” 

headline, and then click the Head2 tag to apply the tag to this text.

As the Head2 tag is applied, tag markers are displayed at the start and end of the 

tagged text. Th e frame also changes colors, as a tag was applied to it at the same time 

you applied a tag to the headline. Th is is because a frame must have a tag if any of the 

contents are also tagged. Th e tag applied to the frame may be diff erent from the tag 

applied to the text.

8 Continuing to work in the sidebar, click and drag to select the remaining text in 

the third column. Be sure to select all the text that follows the “Super Skiing” headline, 

without selecting the headline itself. With the text selected, click the Body tag in the 

Tags palette.

You have completed tagging all the text in the layout.

9 Choose Edit > Deselect All.

10 Choose File > Save.
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Tagging images

1 In the Tools palette, choose the Selection tool ( ).

2 Click the image of the snow volleyball players in the far left  column to select it. In 

the Tags palette, click the Image tag so that it is applied to this graphic.

3 Click the image of the downhill skier in the second column to select it. Right-click 

(Windows) or Ctrl+click (Mac OS) and choose Tag Frame > Image from the contextual 

menu that is displayed.

You can use the contextual menus to apply tags to frames as well as text.

4 Repeating the process from the previous step, click to select the image of the two 

skiers in the third column, and then right-click (Windows) or Ctrl+click (Mac OS) and 

choose Tag Frame > Image from the contextual menu.

You have completed the process of tagging all the frames for content that will be 

exported as XML.
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Viewing and organizing structure

Before exporting the document as XML, you want to confi rm that the structure of the 

XML matches the hierarchy of your layout. 

1 Choose View > Structure > Show Structure. Th e Structure pane is displayed.

Th e Structure pane displays the tags that have been applied to objects in the layout, in 

the sequence in which they were applied.

Note: You may need to move your Tools palette to view all the contents of the 

Structure pane.

2 In the Structure pane, click the triangle ( ) to the left  of the Root tag. Th e Root 

tag is the highest-level tag; all other tagged objects appear beneath the Root tag. All 

documents must have at least one Root tag. 

Th e Root tag can be renamed if your workfl ow uses a diff erent name for its top-level tag.

3 Click the triangle to the left  of the top Story tag. All the structured elements under 

this tag are displayed, including both Head2 tags and both Body tags.
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You can see the tags that you applied, as well as tags that had been previously applied 

to the document. Th e Head2 and Body tags are children of the Story tag, which was 

previously applied for you. Th e tags are listed in the order they were applied to objects 

on the page, and should match the relationship of objects in the layout. For example, all 

related text is typically placed under the same parent tag. In this case, the Head2 and 

Body tags are related, so they are placed together under the Story tag. Each Head2 tag is 

placed before each Body tag, just as the headlines are before the body text in the layout.

4 In the Structure pane, click the menu in the upper right corner and choose Show 

Text Snippets. Th e Structure pane now shows the fi rst portion of the text to which each 

tag is related.

5 In the Structure pane, click the Head1 Tag, which displays the text snippet “Family 

Fun.” In the layout this is the highest-level headline, placed immediately beneath the 

title. In the Structure pane, this tag is positioned between two Story tags. As a primary 

headline, it should be one of the top-most items in the structure. Because InDesign 

adds items to the Structure pane in the order in which they are tagged, it is incorrectly 

positioned. Click and drag the Head1 tag up so that it is positioned under the Title tag. 

Release the Head1 tag when a black line appears under the Title tag. Th e position of the 

tag in the Structure pane now refl ects the position of this headline in the layout.

Note: InDesign CS2 also supports using DTDs to validate the structure. For more 

information about using DTDs to validate structure see InDesign Help.

6 Choose File > Save.
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Viewing and applying attributes

Tagged objects may also include additional information about the objects. Th is 

information which describes the tagged object is known as an attribute.

1 In the Structure pane, click the triangle to the left  of the top Image tag. InDesign 

displays the attribute icon (•) followed by the location of the image fi le. 

2 Continuing to work in the Structure pane, click to select the Title tag with the text 

snippet “Ski & Snow Report.” Right-click (Windows) or Ctrl+click (Mac OS) the Title 

tag and choose New Attribute. Th e New Attribute window opens.

3 In the New Attribute window, for Name enter Issue_Number. Press the Tab key, 

and for Value enter 12. Click OK and the attribute is added to the Title tag.

Attributes can be used to provide additional descriptive information such as the 

publication date or copyright status.

4 Choose File > Save to save the document.
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Exporting XML

Aft er applying XML tags to the text and graphics in the InDesign layout, you can create 

an XML fi le.

1 Choose File > Export. Th e Export window opens.

2 If necessary, in the Export window, navigate to the Lesson_13 folder, then choose 

XML from the Save as type drop-down menu (Windows) or Format drop-down menu 

(Mac OS). Enter the fi le name snow.xml. Click the Save button and the Export XML 

window opens.
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3 In the Export XML window, click the Images tab. Confi rm that all the options are 

unchecked.

When exporting XML from InDesign CS2, you can have images from the layout copied 

or moved into the same folder as the XML fi le by selecting the options under the Copy 

to Images Sub-folder section of this window. Th is allows for images that have been 

tagged to be re-used in other print or web layouts. Because you will be working with 

the XML fi le using the same computer that extracted the XML, none of these options is 

necessary.

4 Click the Export button. Th e XML fi le is generated. Keep this document open, as 

you will return to work in it later in this lesson.
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Importing XML
Next you will open an existing InDesign layout that already includes XML tags, and you 

will import XML that was created in the previous exercise.

1 Choose File > Open, and open the 13_b.indd fi le in the Lesson_13 folder, on your 

hard disk. 

2 Choose File > Save As, rename the fi le online_brochure.indd, and save it in the 

Lesson_13 folder.

3 Choose View > Structure > Show structure. Th e Structure pane is displayed.

4 In the Structure pane, click the triangle to the left  of the Root tag. All the tags that 

have been applied to objects in this document are displayed. 

Note: Th e top-level structure of the online brochure matches the structure used in the 

original print layout.

5 Choose File > Import XML. Th e Import XML window opens.

In the Import XML window, choose Show XML Import Options and click to select 

the Merge Content radio button. Click to select the snow.xml fi le, then click the Open 

button. Th e XML Import Options window opens.

6 In the XML Import Options window, confi rm the Mode drop-down menu is set to 

Merge content and deselect all the check boxes so that all the options are unchecked, 

and click OK. Th e XML is imported into the horizontal layout designed for on-screen 

viewing.

All the text and graphics which were tagged in the original document are fl owed into 

their new layout. Th e text will be formatted in the next section of this lesson.
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Appending vesus merging XML

When importing XML, you can either append or merge the XML content into your document. 

Appending adds the new XML content to your document, leaving the existing structure and content 

unchanged. Merging replaces existing content and, depending on the options you select, adds new 

content where it fi nds no equivalent elements. You merge XML into a document in the following 

situations:

• Th e document contains placeholder frames that you want to fi ll with the incoming XML fi le.

• Th e document contains XML that you want to replace with the incoming XML fi le.

• Th e document doesn’t contain any XML structure, and you want InDesign to replace the default 

root with the root of the incoming XML fi le.

XML import options

When importing XML fi les using the Merge Content option, the XML Import Options dialog box has 

the following options:

Create link—InDesign creates a link to the XML fi le and lists the XML fi le in the Links palette. If the 

XML fi le changes, the modifi ed link icon is displayed and you can update the XML fi le just as you 

would any other linked item in your layout.

Clone repeating text elements—Replicates the formatting applied to tagged placeholder text for any 

repeating content. Th e tags and structure of the XML content must match the tags and structure in the 

placeholder text. Use this option when importing content with multiple items that all have the same 

structure, such as a list of names and addresses, or products and prices.

Only import elements that match existing structure—Filters the imported XML content to include 

only elements that match the tags and structure in the Structure pane.

Import text elements into tables if tags match—Imports elements into a table if the tags match the 

tags applied to the placeholder table and its cells. Use this option to place database records into a table, 

for example, when generating price lists or inventory sheets.

Do not import contents of whitespace-only elements—Leaves any existing content in place if the 

matching XML content contains only whitespace (such as a return or tab character). Use this option if 

you’ve included text between elements that you want preserved. For example, when laying out recipes 

generated from a database, you might add labels, such as “Ingredients” and “Instructions.” As long as 

the parent element that wraps each recipe contains only whitespace, InDesign leaves the label in place.

Delete elements, frames, and content that do not match imported XML—Removes elements 

that don’t have matches in the XML fi le from the Structure pane and from the layout. For example, 

when importing names and addresses, you might have placeholder text for an element containing 

the company name. If one of the names doesn’t include the company element, InDesign deletes the 

element containing the placeholder text.
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Mapping tags to style

Now that you have imported XML into the document, you will format and style the 

text. Because the document is structured with tags, you will automate the process of 

formatting by establishing a relationship between the tags and styles.

1 In the Structure pane, click the menu option in the upper right corner and choose 

Map Tags to Styles. Th e Map Tags to Styles window opens.

2 In the Map Tags to Styles window, click the Map By Name button. Because this 

document already includes paragraph styles with names that are identical to the XML 

tags, InDesign CS2 can apply styles to this text. Keep the Map Tags to Styles window 

open.

3 Click the Preview checkbox. Th e tagged text becomes formatted as the Paragraph 

styles are applied to it. Click OK.

4 Choose File > Save.
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Using XML snippets
A snippet is an XML fi le that is a full representation of InDesign content, including 

page items and any XML structure applied to those page items. A snippet lets you reuse 

the content, formatting, tags, and structure of a document. You can store snippets in 

an Object library, and place them in other documents. Use snippets to easily reuse 

objects—even those with complex formatting.

1 Choose Window > ski_brochure.indd to switch to the original document you 

worked on earlier in this lesson.

2 Choose the Selection tool ( ), and click anywhere on the document.

3 Choose View > Fit Page in Window.

4 Arrange your application window (Windows) or document window (Mac OS) so 

that you can see both your desktop and the InDesign layout.

5 Click to select the outline image of the snowboarder to the left  of the headline. Th e 

outline of the skier and the arc across the top of the page all become selected, as they are 

part of a group.

6 Click and drag the two images and arc to the desktop of your computer. An icon 

appears on the desktop with a name that begins as Snippet. Th is XML snippet fi le 

includes all the information necessary to reproduce these images in another InDesign 

layout. 

7 Choose Window > online_brochure.indd. If necessary, arrange your InDesign 

windows so that you can see both the snippet fi le you dragged to your desktop as well as 

the InDesign layout.
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8 Click and drag the snippet fi le from your desktop onto your layout. Th e images and 

the arc are imported into the document.

Snippets retain the x and y coordinates of the original objects, making them perfect for 

objects that need to be reused in multiple versions of an identical document. In this 

case, we are using a diff erent sized layout, so we’ll move the images.

9 Click and drag the outline image of the snowboarder and position it to the left  of 

the Snow & Ski Report headline text.

10 Choose File > Save.

Congratulations. You have completed this lesson.

Exploring on your own

1 Explore the Structure pane by right-clicking (Windows) or Ctrl+clicking (Mac OS) 

the various tags. Examine the options available in the Structure pane menu.

2 Apply XML tags to your own document and export the XML. Practice importing 

the XML into another InDesign layout.

3 Import XML into an InDesign layout and map the tags to InDesign styles used in 

the document, formatting the XML text.



Review

Review questions

1 How and why are XML tags used in InDesign CS2?

2 What steps are necessary before an InDesign CS2 layout can be exported as 

XML?

3 What is the Structure pane, and what role does it play in exporting or 

importing XML?

Review answers

1 XML tags are applied to content in an InDesign CS2 layout, including text, 

graphics and frames. Tags describe the content, allowing for it to be exported as 

XML. Additionally, tagged frames can have XML imported into them.

2 Prior to exporting an InDesign CS2 layout as XML, all objects that will be a 

part of the XML must be tagged. Additionally, the sequence of the XML tags must 

be verifi ed in the Structure pane, and any attributes necessary must be added in 

the Structure pane.

3 Th e Structure pane provides a listing of all tagged objects used in an InDesign 

CS2 layout. It is used to import, manage and export XML. It is used to organize 

the hierarchy of tagged objects, apply attributes, and establish the relationship 

between tags and styles.
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