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Introduction
Welcome to the Beehive Solutions User Guide for xml Catalogue Production. Using the 

instructions in this document, you will learn how prepare an xml file from your onix data and 

import it automatically into a catalogue template. You will also learn how to create a catalogue 

template from scratch and how to modify an existing template to suit your needs.

Most members of a publishing organization are not comfortable working directly with xml, 

but would use it if they knew how. This process teaches you how to use an xml file with 

minimal interaction with code, and with absolutely no reason to learn the language itself. 

Anyone can do it!

We hope that this guide will simplify your catalogue production in the following ways:

By eliminating cutting-and-pasting title information from other sources.

By making use of single-source database information to minimize errors.

By encouraging the use of onix bibliographic standards in your organization.

By making every subsequent catalogue even easier to produce, as based on your pre-made 

templates.

On the accompanying CD, you will find all the files you need to complete the steps in the 

catalogue production process. In addition, there is a Video Tutorial that provides a visual 

introduction to the information in this guidebook.

1.

2.

3.

4.
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Transforming Your onix Data
Included with the Beehive Solutions package is a piece of transformation software designed to 

change your onix data feed into an xml document. The Beehive Conversion Interface is a web-

based transformer that you can access on the ccsp website. After uploading your onix file into 

the program, you will have the option to change the order of your titles and request an xml 

version of the information; it is this xml document that you then import into your InDesign 

template.

In addition to transforming the onix to xml, the interface ensures that the xml structure 

complies with the Beehive dtd, which will allow you to use your onix feed with the Beehive 

Template or base your own template on our document structure.

Go to the web address http://www.ccsp.sfu.ca:8080/beehive (you must use a browser that 

supports xml, such as Mozilla Firefox).

Upload your onix file to the interface as requested.

You will then see a list of every title included in the onix feed. Each title’s information can 

be viewed by clicking on the right arrow. This is a visual representation of the structure of 

your xml data.

Move the position of your titles by using the up and down arrows. The order of titles in 

this interface needs to match exactly the order you want for your catalogue.

When you have completed sequencing, choose ‘Export to xml’ and you will receive an xml 

document ready to be imported into your InDesign template.

1.

2.

3.

4.

5.

Note: Image file locations in the xml document must be a local path, 
which will generate automatically from the onix feed. The path it uses 
is “//Images/filename.jpg.” To make sure this matches your image 
locations, you will need to put your image files into a folder named 
‘Images’ within the local folder that contains the xml feed, dtd, and 
catalogue template.
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Working with the Beehive Template
The Beehive Template contains placeholder frames and text that are set up to receive a generic 

set of bibliographic elements typically used in a book publisher’s catalogue. Included in the 

template are layouts for a full-page spread, a half-page spread, and a quarter-page spread (See 

Appendix B for the included elements). In order to customize the design and content of the 

template you may wish to change the shape, size or position of the object frames, apply a 

unique set of character and paragraph styles, and add and/or remove elements altogether. The 

following instructions will guide you through this process.

Getting Started
Open the Beehive Template in InDesign CS2.

Save the template with a new file name.

Choose Window > Tags to open up the Tags window. 

Choose View > Structure and select Show Structure. 

Repeat step 4 to select Show Tag Markers and again to select 

Show Tagged Frames. 

Take a few minutes to familiarize yourself with the generic 

layouts and element names. Being familiar with the template 

will help with decision-making during the design phase.

1.

2.

3.

4.

5.

6.

Selecting these options 
will: a) colour-code 
each object frame to 
match its tag colour, 
and b) enclose any 
individually-tagged 
placeholder text 
with coloured square 
brackets to indicate its 
corresponding tag.
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You will see three pages in the layout and the word catalogue in the Structure pane. The 

Structure pane is where InDesign displays the sequence of xml tags that we have linked to 

objects in the layout. ‘Catalogue’ is the overarching element that contains every entry in the 

final catalogue—pieces like ‘book,’ ‘title,’ ‘contributor,’ and so on. By clicking the grey arrow 

beside ‘catalogue,’ three elements named ‘book’ will appear. Each ‘book’ corresponds to a 

single spread in the layout. By expanding one of the ‘book’ elements using the grey arrow, you 

can see that each one also contains further elements. 
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The layout pages contain coloured boxes (placeholder frames) and text (placeholder text) 

indicating where each piece of a title’s information will appear upon importing your xml data. 

The largest placeholder frame in each spread is tagged as the ‘book’ element, while the smaller 

ones correspond to different elements found within each ‘book’ element in the Structure pane. 

By clicking on a frame in the layout, you will see its corresponding element underlined in the 

Structure pane. A placeholder frame tagged as an element at the lowest level of the document 

structure will only have one type of information in it, while frames tagged with higher-level, or 

parent, elements can contain more than one type of information. For example, the ‘title’ frame 

contains both ‘main_title’ and ‘subtitle,’ but the ‘tagline’ frame only contains the ‘tagline’ 

element. In the normal viewing pane the xml tags are represented as square, coloured brackets, 

but by viewing these frames in the Story Editor (Edit > Edit in Story Editor), you can see the 

xml tags represented as coloured flags. By using placeholder text in the placeholder frames, 

your xml data will automatically inherit the placeholder text style upon import.

This specific order of elements in the structure pane corresponds to the structure of the xml 

data in your source document. It is important that each element is kept in the correct order 

throughout your modifications to the template.
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Modifying the Beehive Template

Working with a Flat Plan
InDesign imports the catalogue content into the template in the exact order that it appears 

in the xml source document. This convention requires that you organize your page layout 

to correspond with that order, ideally using your flat plan, before attempting to import the 

content. A flat plan will help you keep track of the pre-determined content and page allotment 

you can expect for each title. The Beehive Template contains generic page layouts for a full-

page spread, a half-page spread, and a quarter-page spread to get you started. See Duplicating 

Content and Adding Pages on page 24 for detailed instructions on generating more pages for 

your catalogue. 

Working with Existing Elements
If the Beehive Template contains all of the bibliographic elements you plan to import, 

then you can simply modify the existing placeholder frames and text to meet your design 

specifications. (See Appendix B for the included elements.) This includes moving and resizing 

placeholder frames or text and applying unique character and paragraph styles to each element. 

If you move placeholder frames or text, you must be sure that they remain in the same spread 

as their parent element, otherwise you might import a different book’s information. To be 

sure, always refer to the Structure pane to see which elements are underlined when a frame is 

selected.

You are free to move and resize frames anywhere in the spread without affecting the preset 

tags or structure.

Placeholder text identifies the position of each element in the layout and indicates the 

assigned character and paragraph styles. You can modify the styles by accessing the 

Paragraph Styles window. Double-click on a style and make changes within the Paragraph 

Style Options box as you would normally do when working with styles. You are free to 

rename the styles as you see fit.

1.

2.
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Adding New Elements
We have provided tagged placeholder frames that allow you to import a generic set of 

elements; however, you may wish to add or remove elements on any number of pages. You can 

check which elements are currently included in the structure by expanding the ‘book’ element 

in the Structure pane. When you add a new element you need to create a placeholder frame, 

match it to an xml tag, and make sure it fits in the Structure pane.

Adding Placeholder Frames

Create a text frame on the desired page. (If you use the Text tool, you will need to make 

the box on the pasteboard to avoid simply clicking your cursor into one of the  

pre-existing frames.)

To create a link between the frame and a new Structure pane element, select the frame and 

open your Tags window.

Find the corresponding tag in the Tags window, for example, ‘rights,’ and click on it. If the 

text frame was successfully tagged it will have a coloured frame that matches the colour 

swatch associated with ‘rights’ in the Tags window, and a new element ‘rights’ will have 

appeared at the bottom of your Structure pane.

1.

2.

3.
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Once you have created the tagged placeholder frame you must adjust the order of its 

element in the Structure pane to match the structure of your xml data. 

Referring to the Document Structure Diagram located in Appendix A, you will see that 

‘rights’ should be nested between ‘descriptors’ and ‘properties’ within the parent ‘book’ 

element. Right now it is unnested at the bottom of the Structure pane.

4.

5.
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Expand the correct parent ‘book’ element. Click on the ‘rights’ element and drag it to the 

space between ‘descriptors’ and ‘properties.’

6.

Note: If the element is not nested in the 
correct sequence in the structure pane, 
your xml data will not import properly.
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Adding Placeholder Text

Placeholder text is used when the placeholder frame is a parent element that contains one or 

more child elements. For example, the ‘title’ frame in the template contains placeholder text 

tagged as ‘main_title’ and ‘subtitle’. You can have multiple tagged elements in one placeholder 

frame. Coloured brackets surround any tagged placeholder text to indicate its corresponding 

tag. Again, you can always confirm which element the text is linked to by clicking on it and 

checking which element is underlined in the Structure pane.

Decide which element you would like to add to an existing placeholder frame. For this 

example we will use the element ‘print_run,’ which belongs in the ‘properties’ frame.

Select the ‘properties’ frame and open it with Story Editor (Edit > Edit in Story Editor). 

You will see the current placeholder text surrounded by coloured arrows representing their 

tags. It is easier to edit placeholder text in Story Editor so as not to accidentally erase a tag 

and also to understand which elements contain others.

1.

2.

Referring to the Document Structure Diagram in Appendix A, find the position of the 

‘print_run’ element within the hierarchy. Locate the corresponding position in the Story 

Editor and place your cursor there. (Some elements may not be present in the catalogue 

layout.) 

3.
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Type the words print run, or whatever you would like to 

use as the placeholder text (this text will be replaced with 

xml content) and highlight them. 

From the Tags window, select the element ‘print_run.’ 

Confirm that the new element appears in the proper 

order in the Structure pane. (It should appear in the 

correct order because it we placed it within a pre-tagged 

frame, as opposed to tagging placeholder text that has no 

predetermined structural reference.)

4.

5.

6.

Tip: You can use any 
placeholder text you 
wish, but it will be 
easier to keep track of 
what will flow into that 
position if you use the 
element name.



13

Deleting Elements
You may wish to use fewer elements than we have provided in the Beehive Template. There are 

two ways to approach this task.

You may manually delete unwanted frames from the layout before importing the xml. 

Deleting a placeholder frame or text will automatically delete the corresponding element 

from the Structure pane, and vice versa.

You may allow InDesign to delete frames automatically during the import process. See 

Importing XML on page 27 for further explanation of this option.

When you are ready to continue, see Duplicating Content and Adding Pages on page 24.

1.

2.

Or
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Setting Up Your Own Template
Before you begin to set up your InDesign file, you should have a rough plan for the page 

layouts you would like. With your design in hand, refer to the hierarchy of elements in the 

Document Structure Diagram located in Appendix A. It will indicate which frames should be 

tagged as children elements and which should be tagged as parent elements. When you tag a 

frame, your choice will determine what specific information flows into that frame upon import 

of xml. The elements in the Document Structure Diagram that are higher on the branches 

are parent elements, since additional elements branch off from them. Tagging a frame with a 

parent element causes every child element to be flowed into that frame, while tagging a frame 

with a child element will limit the information to that single element. 

For example, a frame tagged as ‘title’ will receive the xml information for both ‘main_title’ and 

‘subtitle,’ while a frame tagged as ‘main_title’ will only receive the information for ‘main title.’ 

However, if you include two frames, one tagged as ‘title’ and one tagged as ‘main_title,’ the 

main title information will appear in the ‘main title’ frame and only the subtitle information 

will appear in the ‘title’ frame. This is the principle of your layout: by first creating a parent 

frame ‘book,’ every child element included in that book’s xml information will be accounted 

for. It is your job to pick and choose the specific elements by creating the appropriate child 

frames and linking them to your chosen catalogue elements.
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Getting Started
Open InDesign CS2 and create a new document template 

that is sized according to your specifications.

Set up your document so that you can work with the 

structure.

Choose Window > Tags to open up the Tags window. 

Choose View > Structure and select Show Structure. 

Do this two more times to select Show Tag Markers and 

Show Tagged Frames. 

Importing a DTD
To start, import tags from your dtd:

From your Tags window menu, select Load dtd and select 

the appropriate dtd file (beehive.dtd).

You will now see a list of tags and accompanying colour 

swatches in your Tags window. The colour swatches are 

random, so yours might be different than the ones shown 

here; however, you may change the associated colour of a 

tag by double-clicking on it.

1.

2.

3.

4.

1.

2.

Note: If you have 
selected the Show Tag 
Markers and Show 
Tagged Frames from 
View > Structure pane, 
you will see that an 
object frame is colour-
coded to match its tag 
colour. This colour does 
not show up in the print 
process nor in Preview 
mode.
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Setting Up the Document Structure
In the Structure pane, you will see the word Root. This is 

InDesign’s name for its default parent tag. Yours will be 

‘catalogue,’ since it is the highest-level element according 

to our Document Structure Diagram (see Appendix A). 

Select ‘Root,’ and re-tag it to ‘catalogue’ by clicking on 

the catalogue tag in your Tags window. 

Create a text frame on your first page and tag it as ‘book.’ 

You will see that a corresponding ‘book’ element has 

appeared nested under ‘catalogue’ in the Structure pane. 

You will now begin creating your chosen children 

elements for the initial layout pages by setting up each 

layout you require, for example, a full-page, a half-page, 

and a quarter-page spread. (You can insert extra pages and 

copy the layout at a later step in the process.)

1.

2.

3.
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Creating New Elements
There are two ways to create frames and content holders in InDesign:

Structure First, Layout Second

Make a new child element of ‘book’ by selecting the ‘book’ element in the Structure pane 

and choosing Add New Element from the menu. 

Select the desired tag, for example, ‘title.’

Continue to make elements based on the 

Document Structure Diagram that follow 

the parent/child hierarchy. To ensure you’re 

nesting elements correctly, make sure you have 

highlighted the correct parent element when 

creating children. The elements can be moved 

after they are made, in case of any errors.

1.

2.

3.
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Once your Structure pane is complete, you can link your elements to text frames on the 

page by dragging the element name from the Structure pane and dropping it into the 

appropriate frame. You can check to see that the frame was tagged correctly by selecting 

it—its corresponding element will be underlined in the Structure pane.

For more information, see Hints for Creating New Elements on page 20.

4.
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Layout First, Structure Second

Create a text frame in your layout.

While the frame is selected, click on a corresponding tag from your Tags window, for 

example, ‘title.’

You will see that a new element, ‘title’ in this case, has appeared at the bottom of your 

Structure pane.

Now that you have tagged the placeholder frame, you must adjust the order of its element 

in the Structure pane to match the structure of your xml data. 

Referring to your Document Structure Diagram you will see that ‘title’ should be a nested 

child of the ‘book’ element and preceding any other children elements you may have 

created. Right now it is unnested and at the bottom of the Structure pane.

Drag and drop your new element to its appropriate location. Dropping it onto another 

element will nest it below that element.

Continue to create and tag your text frames according to the Document Structure Diagram 

until all of your chosen elements are included.

For more information, see Hints for Creating New Elements on page 20.

1.

2.

3.

4.

5.

6.

7.
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Hints for Creating New Elements

It is not necessary to use every element in the Document Structure Diagram; you may 

choose a select number to suit your needs. However, it is necessary that the elements are 

in identical order to the Document Structure Diagram. So every child element you use 

must be nested under its parent element. For example, if you choose to use the element 

‘main_title,’ but not ‘subtitle,’ you must still create the parent element ‘title.’ But you 

are not required to create an element named ‘subtitle.’ However, if you want both ‘title’ 

and ‘subtitle’ to import into the same tagged ‘title’ frame, you do need to include them 

both as elements in the structure pane, regardless of whether they have their own tagged 

placeholder frames.

You can also include different elements in different book spreads, so pick and choose them 

according to your desired layout.

If you wish to import an image (the book cover, for example), you must create an object 

frame—not a text frame. Image elements are represented as ovals in the Document 

Structure Diagram.

1.

2.

3.
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Adding Placeholder Text
Placeholder text is used when the frame is tagged as a parent 

element that contains one or more child elements. For 

example, the ‘title’ frame could contain placeholder text 

tagged as ‘main_title’ and ‘subtitle’ (see the Beehive Template 

for an example). You can have multiple tagged elements in 

one placeholder frame. Placeholder text is useful for several 

reasons: 

a) To indicate which elements will import into which frame, 

particularly when dealing with multiple children in one 

parent frame.

b) To get a better sense of what your design will look like.

c) To ensure that the styles applied to placeholder text will be 

inherited automatically by your imported xml.

Note: Coloured 
brackets surround 
tagged placeholder 
text to indicate its 
corresponding tag. You 
can also confirm which 
element the text is 
linked to by clicking on 
it and checking which 
element is underlined in 
the Structure pane.
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Hint: You can also type the placeholder text words before having tagged the 
appropriate child element in that frame. You can write it and then tag it, and a new 
element will appear nested below your chosen frame element in the Structure pane 
(you only need to confirm that it is in the correct order). For example, if you have 
a frame tagged as ‘title,’ but you haven’t yet inserted ‘subtitle’ into the structure 
pane, you can type the word ‘subtitle’ (or whatever text you want) into the ‘title’ 
frame, highlight them, and click on the ‘subtitle’ tag in the Tags window. A new 
element called ‘subtitle’ should appear in the Structure pane, nested under ‘title.’

To add placeholder text to a placeholder frame, select the appropriate frame, for example, 

the ‘title’ frame that contains the children elements ‘main_title’ and ‘subtitle.’

Open the frame with Story Editor (View > Edit in Story Editor). You will see coloured 

arrows indicating the tags ‘main_title’ and ‘subtitle.’ It is easier to edit placeholder text  

in Story Editor so as not to accidentally erase a tag and also to understand which  

elements contain others.

1.

2.

Place your cursor between the two coloured arrows of one of the tags, such as ‘subtitle,’ 

and type the word subtitle. Tip: You can use any text you wish, but it will be easier to  

keep track of what will flow into that position if you use the element name as the 

placeholder text.

3.

Do the same for any other tags in that frame, and for any other frames that you wish to 

have placeholder text.

4.



23

Applying Styles to Placeholder Text
Styling works the same for placeholder text as text in any other InDesign document.  

We suggest using paragraph styles to keep track of the different formatting, but simply 

changing the font and formatting of specific text will work as well.

If you use style sheets, try to name them according to your chosen layouts, such as 

‘Full Page Catalogue Copy’ and ‘Half Page Subtitle,’ or whatever else will help you keep 

track of your many layouts.

You may use different styles for child placeholder text in the same frame, such as  

‘main_title’ and ‘subtitle’ in the ‘title’ frame.

1.

2.
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Duplicating Content and Adding Pages
When making your catalogue longer, you must always be careful to match the layout sequence 

to the sequence of the ‘book’ elements in the structure pane. The easiest way to add pages is:

In the Pages pane, select Insert Pages from the menu. 

(The Duplicate Pages option will affect the nesting of the 

structure, so we suggest you do not use it.)

Insert the number of pages you wish to add to the 

document. This will create a number of blank pages onto 

which you can then copy the templates.

To duplicate the content of a template page, you must 

select all the placeholder frames and objects on each page 

and copy and paste them onto a newly inserted blank 

page (or, in the case of half- and quarter-pages, you can 

paste them into the empty halves or quarters).

1.

2.

3.

Note: The Beehive 
Template does not 
make use of master 
pages, but you are free 
to set them up as you 
wish for objects like 
page numbers, logo, 
grid, etc. However, 
frames placed on the 
master page will not 
accept imported xml 
data (even if tagged 
accordingly).
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As you paste the selection, a new ‘book’ element will 

appear at the bottom of the Structure pane.

It is important that these books are kept in the same order 

as the layout sequence, so every time you paste a new set 

of placeholders, click on the new book element and drag 

it to its proper location in the Structure pane. 

4.

5.

Tips for organizing 
your elements: a) 
Select a ‘book’ 
frame to underline its 
corresponding element 
in the Structure pane; 
b) expand one of the 
‘book’ elements as a 
reference point for 
moving the others; c) 
since the new elements 
appear at the bottom 
of the structure pane, 
pasting every spread 
after the previous one 
should keep them in 
order.
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For half- and quarter-page layouts, multiple spreads can be 

copied and pasted together, but remember that multiple 

‘book’ elements will appear in the Structure pane that then 

need to be placed in the correct order.

Continue to insert pages and copy your layouts until you 

have prepared a catalogue template that conforms to your flat 

plan in both number of pages and types of spreads.

See Importing xml on page 27 when your template is complete.

6.

7.

8.

Note: It is easier to 
add new pages to the 
template before the 
xml has been imported; 
it is also easier to 
make any stylistic or 
element changes to 
the template before 
copying the spreads.
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Importing XML
Choose File > Import xml.

Select the xml source file you wish to import.

Confirm that Show xml Import Options and Merge 

Content are selected in the grey dialogue box at the 

bottom of the Import xml window and click Open.

Select the desired import options in the xml Import 

Options window. See Import Options on page 28 for a 

description of the choices.

Click OK.

Resize images and adjust placeholder frames to account 

for text overset.

1.

2.

3.

4.

5.

6.

Note: The coloured 
frames and brackets 
will not print out, just 
as they are hidden 
when InDesign is in 
Preview mode.
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Import Options
When importing the xml you can choose from six import options.

Create link

This option creates a link between the xml source document and InDesign, allowing InDesign 

to automatically update content changes made to the xml source document.

Clone repeating text elements

This option refers to instances of multiple elements, for example, when a book has more than 

one contributor. Rather than including two contributor elements in the structure pane a priori, 

this option will automatically create the second instance for you during the import process.

Only import elements that match existing structure

In general, this option is useful as it automatically excludes xml content that appears in the 

source document but does not have a place created for it in the layout. However, you may 

want to deselect it if you want to flow in all of the content and then manually choose what to 

discard after the import process. Elements that do not correspond to tagged placeholder frames 

or text will flow into the main ‘book’ element frame.

Import text elements into tables if tags match

For catalogue production purposes layouts do not generally require tables (we suggest avoiding 

the use of tables for simplicity’s sake), so this option is unnecessary.

Do not import contents of whitespace—only elements

This option allows you to choose whether you want to preserve formatting from the source 

document or from the layout. When using placeholder text this option should be selected to 

preserve the layout formatting. 

Delete elements, frames, and content that do not match imported xml

This will automatically delete placeholder frames and content that do not appear in the xml 

source document. 
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Appendices
The appendices are designed to help you if you encounter any difficulty with the process. The 

Document Structure Diagram in Appendix A illustrates the structure of the xml file, which 

will be useful for reference throughout the process. Appendix B contains lists of the elements 

included in the three Beehive Template spreads, to help you make your decision about which 

to keep, add, or delete, when making your own template. Appendix C is a glossary of some of 

the terms we have used throughout this document. 

Appendix D is the Beehive cd on which you will find every file that is required for this 

catalogue production process:

user_guide.pdf: this user guide in electronic form

video_tutorial.mov: a Video Tutorial to familiarize yourself with importing xml

beehive_template.indd: the Beehive Template that you may modify to suit your needs

beehive.dtd: the dtd file to load into your own template

onixfeed.xml: Beehive’s sample onix file for practice conversions 

bookfeed.xml: Beehive’s sample xml file for practice catalogues

Images (folder): contains the images required for the bookfeed.xml document

beehive.pdf: the final project document of Beehive Solutions from the CCSP at SFU

For more resources on using xml in InDesign CS2, visit the Adobe website:

http://www.adobe.com/products/indesign/xml_scripting.html

•

•

•

•

•

•

•

•
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Appendix A: Document Structure Diagram
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Appendix B: Beehive Template Elements 

Full-Page Spread Half-Page Spread Quarter-Page Spread
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Appendix C: Glossary

Append

When importing xml, you can either append or merge the xml content into a document. 

Appending adds the new xml content to your document, leaving the existing structure and 

content unchanged. See Merge.

Attribute

A description of an xml element consisting of both a name and a value. Attributes are visible 

in the Structure pane, not in the layout. See Structure Pane.

Bibliographic Data

Title information which publishers collect and index. Bibliographic data can be transmitted in 

onix form.

Catalogue

A printed resource (such as a book or pamphlet) containing descriptive information about 

book titles that comprise a publisher’s list: author, publisher, price, isbn etc.

Child Element

Any element contained within another element (parent) in a content hierarchy. See Nested 

Elements.

Cloning

A function in InDesign CS2 that repeats formatting as many times as required for all of the 

content, such as repeating elements in xml. See Repeating Elements.

Document Structure Diagram

A schematic representation of pieces information and their relationships in a tree-style 

diagram. See Nested Elements.

dtd (Document Type Definition)

A declaration in an xml document that specifies constraints on the structure of the document.
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Element

An element is an xml tag that appears in the Structure pane when you tag a page item. Child 

elements are subordinate to parent elements in the structure.

Flat Plan

A designer’s initial layout plan detailing where each section of a printed document will be 

placed. For catalogue production, the flat plan contains the hierarchy and placement of 

individual books.

InDesign

Adobe’s page layout and design software that enables designers to create page templates for 

books, catalogues, etc. The most recent version is packaged in the CS2 suite, and features 

updated xml functionality from CS and earlier versions.

Master Page

In InDesign, a layout that is applied to every page or individual pages within a document.

Merge

Merging xml content into a document replaces existing content and adds new content where it 

finds no equivalent elements. See Append.

Metadata

Data about data. For example, bibliographic data for a given book, describing author, title, 

isbn, format, etc. xml is a language that can be used to label pieces of information using 

metadata tags.

Nested Elements

xml tags that are structured according to hierarchy, with higher-level tags (parents) containing 

one or more lower-level tags (children). See Document Structure Diagram.

ONIX (Online Information Exchange)

The international standard for representing and communicating book industry product 

information in electronic form.
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Parent Element

A relative term describing any element in a heirarchy that branches into at least one lower-level 

element, known as a child element. See Nested Elements.

Parent Placeholder Frame

An InDesign text frame that is tagged to receive xml data for a parent element. Within the 

Beehive Template the main parent placeholder frame ‘title’ contains all the child placeholder 

text for a given title.

Placeholder Frame

A text or graphic frame placed into a layout template that can be tagged and filled with 

imported data. See Placeholder Text.

Placeholder Text

Filler text that can be placed in a layout template prior to the actual content being imported. 

See Placeholder Frame.

Repeating Elements

A child element that appears more than once under a parent element within an xml source 

document. For book information, this could be the presence of two authors or two subjects.

Root Element

The starting point of an xml document; it encloses all following elements and is therefore the 

parent element to all the others.

Story

In InDesign CS2, a text box that contains text and/or objects such as text boxes. When 

working with xml, a story frame is generally associated with a parent element, such as ‘book’.

Story Editor

A feature in InDesign CS2 that allows the designer to work on the content of the document 

separate from the layout. Tags are represented as icons surrounding the text that they mark. To 

prevent accidentally deleting placeholder text tags, it is best to edit the catalogue text in Story 

Editor.
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Structure

The hierarchical arrangement of elements within a tagged document.

Structure Pane

A hierarchical display of tagged page items and imported xml content used in InDesign. Items 

that appear in the Structure pane are called elements. The Structure pane shows at a glance 

what elements have been placed on the page and what have not.

Styles

The application of formatting to a section or element of text. Styles can be applied both to 

characters and paragraphs. Styles can also be associated with xml element tags.

Tag

A label for a piece of data in an xml file; must be enclosed in angle brackets, like <main_title>. 

There are two types of tags. The first tag marks the beginning of a piece of data while the 

second tag marks the completion of that data. For example: <main_title>Hamlet</main_

title>.  In Indesign, tags are repsented with coloured brackets and arrow icons.

Templates

A set of pre-designed formats for text and graphics on which new pages can be based. After a 

page is created using a template, you can further customize the design.

XML (Extensible Markup Language)

A simple way to label pieces of information in a text file. xml does not limit the number of 

tags you can use and it does not determine how data should look, it simply describes it.


